Dieser Artikel ist auch verfügbar in:
Der folgende Artikel erklärt einen Workflow für fortgeschrittene Benutzer, die ihre Twinmotion- oder Unreal Engine-Szene in HEGIAS VR importieren möchten.

Twinmotion unterstützt derzeit keinen direkten Export. Es ist jedoch möglich, Ihre Szene mit dem Twinmotion Datasmith Plugin in Unreal Engine zu importieren und die Szene von dort aus zu exportieren. Wenn sich Ihre Szene bereits in der Unreal Engine befindet, können Sie die ersten beiden Schritte überspringen.

Installation
Für diesen Prozess müssen Sie die folgende Liste von Programmen und Plugins installieren. Die genannten Versionen wurden zum Zeitpunkt des Schreibens verwendet und getestet.
Twinmotion
Unreal Engine (4.27.2)
Plugin 1: Datasmith Twinmotion Importer Plugin (Beta 4)
Plugin 2: Twinmotion Content for Unreal Engine Plugin (Beta 4)
Optionales Plugin 3: glTF Exporter
Sie können die Plugins direkt über den Epic Games Launcher installieren. Gehen Sie zum Marketplace und suchen Sie dort nach dem jeweiligen Plugin.


Twinmotion-Szene in Unreal Engine importieren
Starten Sie Unreal Engine
Erstellen Sie ein neues leeres Projekt. Löschen Sie alle unerwünschten Inhalte aus dem Outliner-Fenster.
Activate Plugins: Klicken Sie auf Plugins verwalten... und aktivieren Sie alle zuvor installierten Plugins. Die Registerkarte des Plugins-Browsers finden Sie auch unter Bearbeiten > Plugins. Starten Sie Unreal Engine neu, um fortzufahren.

Klicken Sie auf Datasmith und navigieren Sie zu Ihrer Twinmotion-Datei (*.tm). Wählen Sie sie aus und importieren Sie sie mit den Standardeinstellungen. Dadurch wird Ihre Twinmotion-Szene in die Unreal Engine importiert.


Unreal Engine Projekt für HEGIAS exportieren
Option 1: FBX
Wählen Sie diese Option, wenn Sie vorhaben, Ihr Modell mit dynamischen Materialien direkt in HEGIAS VR zu materialisieren.
Wählen Sie alles aus, was Sie exportieren möchten
Wählen Sie Datei > Ausgewählte exportieren... und speichern Sie Ihre Datei am gewünschten Ort im FBX-Format. Verwenden Sie die FBX-Exportoptionen aus dem untenstehenden Bild:

Optional: Um einzelne Materialtexturen zu exportieren, rechtsklicken Sie sie im Inhaltsbrowser und wählen Sie Asset-Aktionen > Exportieren..., um sie in denselben Ordner zu exportieren wie Ihre zuvor exportierte FBX-Datei.

Laden Sie Ihre FBX-Datei und Ihre Texturen auf die HEGIAS-Plattform hoch.

Option 2: GLB
Wählen Sie diese Option, um Ihre Szene mit allen Materialien in eine einzige Datei zu exportieren. Möglicherweise können Sie die Materialien anschließend nicht mehr ändern.
Wählen Sie alles aus, was Sie exportieren möchten
Wählen Sie Datei > Ausgewählte exportieren... und speichern Sie Ihre Datei an dem gewünschten Ort. Verwenden Sie dieses Mal das Format *.glb. Verwenden Sie die GLB-Exportoptionen aus dem Bild unten (Animations-, Szenen- und Varianten-Optionen sind deaktiviert):

Laden Sie Ihre GLB-Datei auf die HEGIAS-Plattform hoch:

Objekterkennung
Möglicherweise müssen Sie einige der Meshes in Ihrem Modell (z. B. Böden) manuell umbenennen, damit die HEGIAS-Objekterkennung funktioniert. Eine vollständige Liste der erkannten Schlüsselwörter und ihrer Funktionen finden Sie hier: Features im Modell erkennen
War dieser Beitrag hilfreich?
Stornieren
Danke!