This article is also available in:
The following article explains a workflow for advanced users that want to import their Twinmotion or Unreal Engine scene into HEGIAS VR.

Twinmotion doesn't currently support a direct export. However, it is possible to import your scene to Unreal Engine with their Twinmotion Datasmith Plugin and export the scene from there. If your scene is already in Unreal Engine, you can skip the first two steps.

Installation
For this process you need to install the following list of programs and plugins. The marked versions were used and tested at the time of writing but later versions might have been published.
Twinmotion
Unreal Engine (4.27.2)
Plugin 1: Datasmith Twinmotion Importer Plugin (Beta 4)
Plugin 2: Twinmotion Content for Unreal Engine Plugin (Beta 4)
Optional Plugin 3: glTF Exporter
You can install the plugins directly from the Epic Games Launcher. Go to Marketplace and install each plugin from there.


Import Twinmotion Scene to Unreal Engine
Launch Unreal Engine
Create new empty project. Delete any unwanted content from the outliner window.
Activate plugins: Click on Manage Plugins... and Enable all previously installed plugins. The plugins browser tab can also be found under Edit > Plugins. Restart Unreal Engine to proceed.

Click on Datasmith and navigate to your Twinmotion file (*.tm). Select and import it with default settings. This will import your Twinmotion Scene to Unreal Engine.


Export Unreal Engine Project for HEGIAS
Option 1: FBX
Chose this option if you plan to materialize your model with dynamic materials directly in HEGIAS VR.
Select everything you want to export
Select File > Export Selected... and save your file in the desired location in the FBX format. Use the FBX Export Options from the image below:

Optional: To export single material textures, right-click them in the content browser and select Asset Actions > Export... to export them to the same folder as your previously exported FBX file.

Upload your FBX File and your textures to the HEGIAS platform.

Option 2: GLB
Chose this option to export your scene with all materials to a single file. You might not be able to change the materials afterwards.
Select everything you want to export
Select File > Export Selected... and save your file in the desired location. This time, use the *.glb format. Use the GLB Export Options from the image below (Animation, Scene and Variant Sets are deactivated):

Upload your GLB File to the HEGIAS platform.

Object recognition
You might have to manually rename some of the meshes in your model (eg. floors) for the HEGIAS object recognition to work. A full list of recognized keywords and their functionality can be found here: Detect features in the model
Was this article helpful?
Cancel
Thank you!