> ## Knowledge Base Index
> Fetch the complete knowledge base index at: https://support.hegias.com/sitemap.xml
> Use this file to discover available pages before exploring further.
> Pure-Markdown content can be obtained by appending a '.md' suffix to the content URLs listed in the sitemap (without the trailing slash).

# Twinmotion und Unreal Engine

Der folgende Artikel erklärt einen Workflow für fortgeschrittene Benutzer, die ihre Twinmotion- oder Unreal Engine-Szene in HEGIAS VR importieren möchten. 

Twinmotion unterstützt derzeit keinen direkten Export. Es ist jedoch möglich, Ihre Szene mit dem Twinmotion Datasmith Plugin in Unreal Engine zu importieren und die Szene von dort aus zu exportieren. Wenn sich Ihre Szene bereits in der Unreal Engine befindet, können Sie die ersten beiden Schritte überspringen. 

### Installation
Für diesen Prozess müssen Sie die folgende Liste von Programmen und Plugins installieren. Die genannten Versionen wurden zum Zeitpunkt des Schreibens verwendet und getestet. 
* [Twinmotion](https://www.twinmotion.com/en-US/download)
* [Unreal Engine (4.27.2)](https://www.unrealengine.com/en-US/download)
* Plugin 1: [Datasmith Twinmotion Importer Plugin (Beta 4)](https://www.unrealengine.com/marketplace/en-US/product/21cab2d84a794b7bab359eb1ba5d3e74)
* Plugin 2: [Twinmotion Content for Unreal Engine Plugin (Beta 4)](https://www.unrealengine.com/marketplace/en-US/product/twinmotion-content-for-unreal-engine-plugin-beta)
* Optionales Plugin 3: [glTF Exporter](https://www.unrealengine.com/marketplace/en-US/product/gltf-exporter)
Sie können die Plugins direkt über den Epic Games Launcher installieren. Gehen Sie zum Marketplace und suchen Sie dort nach dem jeweiligen Plugin. 
[![](https://storage.crisp.chat/users/helpdesk/website/f21390e955059800/00_18us9dj.png)](#openImage)

### Twinmotion-Szene in Unreal Engine importieren
1. Starten Sie Unreal Engine
2. Erstellen Sie ein neues leeres Projekt. Löschen Sie alle unerwünschten Inhalte aus dem Outliner-Fenster. 
3. Activate Plugins: Klicken Sie auf **Plugins verwalten...** und **aktivieren** Sie alle zuvor installierten Plugins. Die Registerkarte des Plugins-Browsers finden Sie auch unter **Bearbeiten > Plugins**. Starten Sie Unreal Engine neu, um fortzufahren. 
[![](https://storage.crisp.chat/users/helpdesk/website/f21390e955059800/02a_1aw6ht4.png)](#openImage)
4. Klicken Sie auf **Datasmith** und navigieren Sie zu Ihrer Twinmotion-Datei (*.tm). Wählen Sie sie aus und importieren Sie sie mit den Standardeinstellungen. Dadurch wird Ihre Twinmotion-Szene in die Unreal Engine importiert. 
[![](https://storage.crisp.chat/users/helpdesk/website/f21390e955059800/image_8z86g0.png)](#openImage)

### Unreal Engine Projekt für HEGIAS exportieren
###### Option 1: FBX
Wählen Sie diese Option, wenn Sie vorhaben, Ihr Modell mit dynamischen Materialien direkt in HEGIAS VR zu materialisieren. 
1. Wählen Sie alles aus, was Sie exportieren möchten
2. Wählen Sie **Datei > Ausgewählte exportieren...** und speichern Sie Ihre Datei am gewünschten Ort im FBX-Format. Verwenden Sie die FBX-Exportoptionen aus dem untenstehenden Bild: 
[![](https://storage.crisp.chat/users/helpdesk/website/f21390e955059800/03_1yo87nb.png)](#openImage)
3. Optional: Um einzelne Materialtexturen zu exportieren, **rechtsklicken** Sie sie im Inhaltsbrowser und wählen Sie **Asset-Aktionen > Exportieren...**, um sie in denselben Ordner zu exportieren wie Ihre zuvor exportierte FBX-Datei. 
[![](https://storage.crisp.chat/users/helpdesk/website/f21390e955059800/05_hkustr.png)](#openImage)
4. [Laden Sie Ihre FBX-Datei und Ihre Texturen auf die HEGIAS-Plattform hoch.](/de/article/import-a-scene-to-the-hegias-platform-18p37ao/)

###### Option 2: GLB
Wählen Sie diese Option, um Ihre Szene mit allen Materialien in eine einzige Datei zu exportieren. Möglicherweise können Sie die Materialien anschließend nicht mehr ändern. 
1. Wählen Sie alles aus, was Sie exportieren möchten
2. Wählen Sie **Datei > Ausgewählte exportieren...** und speichern Sie Ihre Datei an dem gewünschten Ort. Verwenden Sie dieses Mal das Format *.glb. Verwenden Sie die GLB-Exportoptionen aus dem Bild unten (Animations-, Szenen- und Varianten-Optionen sind deaktiviert): 
[![](https://storage.crisp.chat/users/helpdesk/website/f21390e955059800/06_1spyvjj.png)](#openImage)
3. [Laden Sie Ihre GLB-Datei auf die HEGIAS-Plattform hoch:](/de/article/import-a-scene-to-the-hegias-platform-18p37ao/)

## Objekterkennung
Möglicherweise müssen Sie einige der Meshes in Ihrem Modell (z. B. Böden) manuell umbenennen, damit die HEGIAS-Objekterkennung funktioniert. Eine vollständige Liste der erkannten Schlüsselwörter und ihrer Funktionen finden Sie hier: [Features im Modell erkennen](/de/article/features-im-modell-erkennen-ha0zv0/)